Datacollect delivery
Incident Report for AB Tasty
Resolved
This incident has been resolved.
Posted 7 months ago. May 11, 2017 - 15:16 UTC
Identified
We encountered a delivery problem on the reporting since 2:50 PM (CET)
We identified it and we are trying to fix it asap.
Posted 7 months ago. May 11, 2017 - 14:33 UTC